
 

 

 

 

 

Import bank statement 

Before you can begin with the import of the bank statements, you have to define the clearance 
accounts and formats for  the bank accounts. 

You can define these settings  here: 

 Payments 

 Bank: Basic data 

 Bank accounts 
 

 

format: format of the import file (it depends on the bank) 

delete import file: If this option is activated, the import file will be deleted after a 
successful import. 

clearance real accounts: Clearance account for the real account postings. 

clearance debtors: Clearance account for the debitors 

clearance creditors: Clearance account for the creditors 

autom. suggestion: If no account was found on the import, the clearance account program 
will suggest the clearance account automatically.  

The real account will be suggested if no bank account exists. 

The debitor will be suggested on all receipts. 

The creditor will be suggested on all outgoings. 



 

 

 

 

 

 

Info field 1: Information field which will be displayed if you edit the bank statement. 

Format customer´s data: Should the program take customer´s data into consideration or not 

autom. clearing outing: The program searches and allocates on the import of the bank 
statement automatically. (outgoing payments) 

 Optional: Number of years back from the current year for search of 
open items 

autom. clearing incoming: The program searches and allocates on the import of the bank 
statement automatically. (incoming payments) 

 Optional: Number of years back from the current year for search of 
open items 

Import ZA/ZE: Here you can choose, if you want to import only incoming payments, 
only outgoing payments or everything. 

Excerpt single edit: One stack for each bank statement will be created 

FormatStatementNr: You have the possiblity to set the option “format bank statement 
number” with a special format. (at the moment JJIII/SSS at the format 
MT940) 

 JJ = Year 

 III = bank statement number 

 SSS= page 

 The program will use the bank statement number (III) as internal 
voucher number and put it in automatically. As external voucher 
number the program will use the complete format (JJIII/SSS). 

The input field for the voucher number is inactive at the posting 
screen. 

clearing account: Account, which should be used on the posting process for an 
automatic created position split. 

account: Account, which should be suggested on the posting of the bank 
statement. 

voucher type: Voucher type, which should be suggested on the posting of the bank 
statement. 

Bank/subsidiaries: The 3digit bankcode/subsidiarycode will put in front of the 
debitors/creditors bank (only HVB bank hungary) 

Search vouchernr. outgoing: The program will take the 1st numeric value and put it in as voucher 
number automatically. (only outgoing, MT940) 

Search vouchernr. incoming: The program will take the 1st numeric value and put it in as voucher 
number automatically. (only incoming, MT940) 

div. parameters: Here you have the possibilty to define some parameters. 



 

 

 

 

 

 

parameter 1: 
Use the first 20 digits of the posting text as assignment number 

parameter 2: 
On the import of the bank statement the program will search for the internal and external voucher 
number of the open items of the found debitor/creditor within the posting text of the bank statement. 
When the voucher number has been found, it will check the amount with the amount of the open item. 
If they match, this voucher (invoice) will be cleared automatically. This automatic clearance will be 
marked with a yellow circle in the edit screen. 
 
parameter 3: 
If the amount is unique within the open items of the already found account, the program will do an 
automatic assignment. The status will be displayed as a yellow circle with the blue “useraction”-picture 
on the right. 

parameter 4: 
If the amount and the internal/external voucher number is unique in all open items, the program will do 
an automatic assignment. The status will be displayed as a yellow circle with the red “useraction”-
picture on the right. 
 
parameter 5: 
If you activate this parameter, you will see the opening/closing balance according to the bank 
statement and according to the bank account on the edit-screen. (only available for MT940 Austria) 
 
parameter 6: 
The posting text will be structured as follows: External voucher number + name of the 
customer/supplier 
 
parameter 7: 
The bank statement will be checked only (without posting!) 
 
parameter 8: 
The posting text will be imported empty – only entries from the user during the edit process will be 
posted later 
 
parameter 9: 
The messages from debtors/creditors will be displayed within the edit screen (tooltipp) 
 
parameter 10 + 11: 
Search with a special format (e.g. F#######) within the text of the bank statement and use this value 
as internal/external voucher number. 



 

 

 

 

 

 
parameter 12: 
Only for format CAMT.053 
The value of field payment reference will be interpreted as customer´s data 
 
parameter 13: 
Only for format CAMT.053 
The value of field note for payee will be interpreted as customer´s data 



 

 

 

 

 

Customer´s data – voucher types 

 

If you have changed the option “Format customer´s data” to “considerate”, the customer´s data of the 
payments will be compared with the customer´s data within the open items later. 
 
But you will need the following setting on the desired voucher types too: 

 Basic data 

 Company index 

 Voucher types 
 

 
 
Choose the desired format of the customer´s data here. 
 
All existing OI´s will be filled with the field customer´s data immediately! This process can take some 
time. 



 

 

 

 

 

Account – Terms 

You can find this basic data program under: 

 Payments 

 Bank Statements 

 Basic data 

 Account – Terms 
 

 
 
Here you can enter some terms, which will be searched within the text of the bank statement. 
 
If the program will find one of these terms during the import within the text, it will use the associated 
account automatically. 
 
Every term can only used once! 
 
Check “P” (priority): 
With this check you set a higher priority than an entered bank account on debtor/creditor side. 
 
Example: 
Creditor "leasing company" - bank account has been entered 
 
Cost account "leasing" - term "leasing" - without priority 
=> the creditor will be suggested 
 
Cost account "leasing" - term "leasing" - with priority 
=> the cost account will be suggested 
 
 
Cost centre / Cost unit / Code 
 
You are able to enter a cost centre, a cost unit and a tax code in addition to the account number. 
This information will be suggested as well if the text has been found.



 

 

 

 

 

Import of the bank statement 

You can find the import of the bank statement here: 

 Payments 

 Bank Statements 

 Import 

bank account: Selection of the bank account (bank statement) 

import file: Enter of the import file (bank statement file) 

 or File => Open (CTRL+O) 

With F11 you can execute the analysis, which bank account with which amount exists in the bank 
statement file. The cause of this analysis is, that there exists more bank accounts in one file on the 
HVB bank. (foreign currency banks too). 

With click on the button „Import“ the import starts. You will get one stack for each bank account which 
you have to complete. Foreign currency banks will not be imported! 

 



 

 

 

 

 

Protocol of the imported bank statement 

You can print a protocol about the import. You find it here: 

 Payments 

 Bank Statements 

 Bank Statements 

stack: Selection of the stack (created on the import). 

sort: Selection of the sort criteria 

status vouchers: Print out all, found, not found 

status accounts: Print out only these, where the program found an account or the 
program didn´t find an account. 

 



 

 

 

 

 

Edit of the imported bank statement 

You also have the possibility to edit the stack. You find it here: 

 Payments 

 Bank Statements 

 Edit 

stack: Selection of the stack (created on the import). 

status vouchers: Display all, found, not found 

status accounts: Display only these, where the program found an account or the 
program didn´t find an account. 

With F11 you can start the „Edit postings“-screen: 

account: Entry/display of the account number. If the account has been found, it 
will be displayed directly. You have the possibility to search for a 
voucher with the *(star)-search or with #(amount)-search. The account 
number will be assumed automatically. 

 With F6 or double click you can start the clearance. This screen is 
exactly the same screen like the screen within the posting online. 

Red X: Nothing has been found (no account, no voucher) 

Blue circle: Parts has been found (at least the account number). It´s possible that 
the amount doesn´t match with OI-amount. In this case you have to 
search for the invoice. 

 

 
 



 

 

 

 

 

Yellow circle: The program did an automatic clearance of an open item as a result of 
(maybe with “useraction”-pic.) activated “div. Parameters”. (for details see “div. parameters” above) 

Green check: The voucher has been found and is ready for posting. 

A graphical overview of the different status values will be displayed on the upper right side in form of a 
bar. 

The part under the edit screen shows detailed informations about the active row. You can change 
the posting text here. 

To delete a single row, click on the menu item “File => Delete”. To delete the whole import for this 
bank account, click on “File => delete selective”. 

On “Edit => Multiple selection” you can change into a special mode, which makes it possible to mark 
more than one row for the delete command. (you can see a yellow headline if it is activated) 

On “Edit => Cost-Split” you can split the costs of a real account posting to different cost centres/cost 
units. A blue star will be displayed if a cost-split exists. If you overwrite the account or the field cost 
centre/cost unit, the cost-split will be deleted automatically. 
(Please notice: the amount you can split is always the net amount!) 

On “Edit => Legend” you have the possibility to display a legend of the different possible statuses.  

You can sort the columns with a double click on the headline (ascending/descending) The sort order 
will be displayed with an orange arrow. 

Function of the right mouse button: 

Only available on the top screen: 

 You have the possibilty to add the bank account of the bank statement to the debitor/creditor 
automatically with the “right mouse button => add bank account” function. (default proposal 
of the status for the bankaccount is inactive) 

The bank details from the statement will be displayed incl. info icon. 

 

 

Blue details for the bank information from the bank statement 

Red The bank information doesn´t exist on the debtor/creditor 

Green The bank information exists on the debtor/creditor already 



 

 

 

 

 

 

 With “positionsplit” you have the possibility to split a desired position on several different 
positions. (debtors/creditors/real accounts) 
You have to use the complete amount before you can quit the split. You can define as many 
accounts as you want. (new row / delete row) 

 

 

When you click on the menu item “positionsplit” on an already splitted position again, you 
enter the split window again which you see above. There you can change the positions. 
The further editing process for split rows is the same as on normal rows. (Stati, assignments, 
tax codes, cost centres/cost units etc.) 
With “delete positionsplit” you can undo the split. 
A splitted position will be posted only if all rows of the split are correct and have an account 
entered. You can choose DEBIT/CREDIT for each split position. 

 If you click the “right mouse button => Refresh”, all search routines will be executed again. Its 
advantage is, that after some changes you don´t have to delete the bank statement and import 
it again. 

Only available on the bottom detail-screen: 

 If you mark a text and click the “right mouse button => add to account terms”, the marked 
text will be added under “Basic data => account terms”. (Requirement: The account has to be 
entered already) 

Example of the clearance screen: 

 

This screen is as same as the screen you know from posting online. If you click F10 to complete the 
clearance, the data will be saved automatically. 



 

 

 

 

 

Posting of the bank statement 

The last step is, to post the bank statement. You can find this program here: 

 Payments 

 Bank Statements 

 Posting 

stack: Selection of the stack, which should be posted. 

voucher type: Selection of the voucher type, which you want to post with. If there is 
entered a contra account on this voucher type, this will be suggested 
as account automatically. 

voucher number: Enter of the voucher number, which the bank statement should be 
posted with. (inactive on use of FormatStatementNr) 

account: Enter of the bank account – will be suggested with the voucher type 
automatically. 

protocol type: Choose if you want to print out a total or an error protocol. 

processing: Choose if you want to check (testing) or post the bank statement. 

All vouchers with green check, yellow circle (incl. useraction) and blue circle will be posted. 

 

 


